Pic2Trip

Website Hosting Down
Resolved

Website is back

Thu, Sep 25, 2025, 12:36 PM
(2 months ago)
·
Affected components

No components marked as affected

Updates

Resolved

Website is back

Thu, Sep 25, 2025, 12:36 PM

Identified

From Web Hosting
We are currently experiencing an unexpected hardware issue on the server where your website is hosted.

Thu, Sep 25, 2025, 12:35 PM

Investigating

Connection timed out. Error code 522

Cloudflare means that Cloudflare was able to connect to its own edge server but could not establish a successful connection to your origin web server.

Thu, Sep 25, 2025, 01:35 AM(11 hours earlier)
Powered by